[jdom-interest] problem creating Document on WebSphere server

John L. Webber - Jentro AG John.Webber at jentro.com
Tue Sep 9 23:44:27 PDT 2003

Hello Rick,

I'm not very familiar with WebSphere, and this is probably OT for the 
JDOM list, but I suspect you'll need to change the java.security
policy for the app server. I had a similar problem with SunOne, which 
was solved by adding the appropriate reflect permissions to the
security file. Don't think this is a JDOM problem...


Langel, Richard wrote:

>We have a utility class jar file that contains classes that create Documents to build XML that is used on both WebSphere app servers and on a Sybase Jaguar server.  We can get everything to work fine on the Jaguar server, and if we create a Document in classes not in the utility jar everything works fine.  But when we try to create a document from a class within the utility jar in WebSphere we get the error below.  The same code from the same jar works fine on the Jaguar server.  Can anyone give me a clue as to what I'm missing?
>	java.lang.IllegalAccessError: <my class> tried to access method org/jdom/Document.<init>()V
 John L. Webber, Software Development
 Peter-Henlein-Strasse 28, 85540 Haar/Munich, Germany
 Tel. +49 89 462 385 0     mailto:John.Webber at jentro.com 
 Fax  +49 89 462 385 29    http://www.jentro.com
NOTICE: The information contained in this e-mail is confidential or may otherwise be legally privileged. It is intended for the named recipient only. If you have received it in error, please notify us immediately by reply or by calling the telephone number above and delete this message and all its attachments without any use or further distribution of its contents. Please note that any unauthorised review, copying, disclosing or otherwise making use of the information is strictly prohibited. Thank you. 

More information about the jdom-interest mailing list